any way to repair Byron Bay?

Hello, folks! I'm prepping a class on interactive fiction, and starting by lining up examples of various kinds (Lost Pig as an example of z-machine based, some InkleWriter works to demonstrate choice-based, etc.)

I planned to use Escape from Byron Bay as an example of a Quest game, but one image in the game is broken, and it's an image that has 1 of the 3 codes required to win the game!

Can anyone tell me what the code is that is on the broken image, OR is there an alternate web location where Byron Bay can be played (and works)? OR, is there a similar Quest example that could be a good substitute? Reasons for using Byron Bay include the length and the implementation of the timer, which would provide a little friendly competition among my students :-)

Any help appreciated, and thanks!

-Doug


Have you tried contacting the author? Is the game being played online or downloaded first? When I downloaded the game and played it offline I didn't see any "broken image"?


I tried contacting the author, but the private messaging was not working (it generated an error for me, although I have not tried it since then to see if the problem recurred).

I was playing the game online because my students are all using Chromebooks and so they will have to play online.

However, just for my own knowledge, how do you download game? I don't see a download link on the game page - just a "PLAY ONLINE" button. I know that this particular game was made available for iPhone, but you meant downloading it to PC and running it like a program, correct?

Many thanks,

-Doug


I found a page in the forum with SOME info:
https://textadventures.co.uk/forum/general/topic/oovbh67pfkgxurl98kytga/how-to-play-downloaded-games

. . . however it's still unclear to me HOW you actually download the game. All I see on a given page is the option to "PLAY ONLINE". Can't right-click on the button to do a "save as", and don't see any other link or button. Apologies if I'm missing something obvious here . . .


(facepalm) Yes, it was obvious. The little "download file" link to the right. Sorry, folks - just distracted by the big, green, candy-like button :-P


If it's a quest game, you might find that some images work only in the Quest app and not online, because filenames online are case-sensitive. If you can find the name of the missing file, check if it's in the downloaded game but capitalised differently. That's easy to fix, and you could upload your own version woth a fix if necessary (though you'd need to change the ID).

If that doesn't work, you could open its game.aslx file in a text editor to find the clue you need.

(Downloaded Quest files are just zip files with a different extension; you can rename them if you want to play around with the files inside them)


mrangel, I have a followup question:

I downloaded the file, and indeed the graphic that is missing in the webplay IS capitalized differently (the file in the archive is "Notepad.JPG" when all the other images are *.jpg. That seems to fit what you said.

I can change the capitalization and also the game ID so I can upload it. But is it possible to upload a game as unlisted? Out of respect for the original author, I do not want to upload an altered version of his game - working or not - for the public without permission.


Yes; you can upload a game as unlisted. That's one of the options whenever you publish a game.

If this works, it may be worth asking the site administrator if they can fix the version that is currently online. I don't think anyone could object to correcting a simple error.


Well, that worked! Thought it was broken at first, but it was just taking a long time to load.

I think there are still a few images in the game that are broken, but at least the code seems to be accessible now.

Confirmed!! Byron Bay is now playable online :-) Still unlisted. Please let me know if I should take any other steps.


You could search the game file for the image names in the .zip file - or just the extensions. Then you can fairly easily check all the images.


I've just tried looking myself; wrote a one line perl script to search the game.aslx file for miscapitalised copies of the filenames. I don't see any errors.

The file Notepad.JPG is indeed capitalised differently from all the other images, but line 1065 of game.aslx is the command picture ("Notepad.JPG") so as far as I'm aware this should work fine. Am I missing something?

Perhaps we're looking at different versions of the game.


Log in to post a reply.

Support

Forums