Simon Says ~ Demo

ScaryCat

Hi, this is my demo version of Simon Says, a psychological horror game, although the labels thriller, puzzle, and mystery could also apply (as well as simply "horror, because there are a few jump-scarish type things, but I tried to rely on things like horrifying realizations"). I was inspired by games like Anna: Extended Version, and Penumbra: Black Plague. Mechanically speaking, it is winnable. There's a lot to figure out, though. If you get stuck, you can either type "help" or "hint". All the music and sound effects are from the Youtube music library, free for use. The artwork is in the public domain, and the photos are marked as "for reuse with modification", "labeled for reuse" "for non-commercial use", by the google search filter.

I tried to make it interesting, without making the story too obvious. You'll have to explore a lot to piece together the whole truth of what's going on, hopefully. Tell me what you think. Was it scary enough? Were the puzzles too easy or too hard? Any glitches?Playthrough transcripts would be much appreciated.

Play here: http://textadventures.co.uk/games/view/7pxk_ils9kysq8rrzcczjw/simon-says-demo-version


XanMag

Had a quick go and ran into some problems:

  1. 'Search pocket' and 'light match' give no responses. I know it switches the items in your inventory, but it would be nice to have a message indicating something has happened.
  2. You cannot light the candle with the match.
  3. For some reason there are a couple attempts - light candle and speak to voice - that bring up a menu with option 2 missing?
  4. A fire is mentioned in the the room but it cannot be seen or interacted with
  5. Once you light the match and try to look at it, the default response of 'it's too dark to make anything out' is given. But... it is a LIT match. I should be able to see something, right?
  6. listen to voice gives a "...but him make no sound" response.
  7. The voice is listed in the inventory pane but there is no mention of a voice at all so I am confused by this
  8. After going back to check the game after typing this, I get a string of 'Hee hee hee. Maybe grapple around' responses set on a timer. Not sure why?

Help me out here and I will be glad to continue testing! Thanks!


ScaryCat

Thanks for the feedback.
I'm going to work on making the commands more consistent. The command in this case is "use match on candle" and then you will be able to see the stuff in the room.
A lot of the time there will be different commands required than the ones on the menu. You'll have to type them in. I'm going to work on cleaning the game up by getting rid of non-functional menu options such as light candle.
I didn't think about adding a description for when the match is first lit, but before it is used on the candle. I'll think about it, but I'm not sure it's necessary. I considered it to be a very weak light source primarily used for lighting stronger light sources, so not that important. But I can see how it would be important for realism, and it would probably be off-putting for the player if they couldn't see it at that point.
You can "Ask voice about -" and "Tell voice about", but otherwise he speaks whenever he is programmed to. You can recognize him by the typewriter effect, when he is calm, and the unscrambling when he is flustered or angry.

The fireplace is to the left.


ScaryCat

Modification update: There is now a message when the candle is lit and a description for the lit match. I also made the voice speak less frequently.


XanMag

Okay... I'm getting along a little easier now, but, here are a few more things I ran into. I understand this is currently in demo form as the title suggests, so some of these may not apply yet.

  1. When I go south into the kitchen, I get stuck. No exits, no description. Same applies when I go north from the parlor. Up the stairs is also a blank room (I assume this one is just an unfinished area of the game).
  2. In the study, there is a broken picture link when entering.
  3. In the study, there is no response when I use chisel on floor. I only noticed that the vase was there after I looked at the floor again.
  4. In the study, when looking at the left or right bookcase, I get the 'nothing out of the ordinary ' response followed by what is on the bookcase.
  5. In the study, I get the 'nothing out of the ordinary' response when I look at the chest and I get a blank response when I open the chest.
  6. In the study, I can move nw or ne and it moves me into the bookcase?
  7. Change the prefix option on the ashes so it reads "...ashes" not "...an ashes"
  8. When trying to get ashes, the help menu pops up?
  9. In the front room, remove the prefix for the book pages.
  10. I can move into the fireplace? Also, while there, there is a switch on/switch off option which gives a blank response. Also, tilting the thing gives no response.
  11. I noticed that in a spot or two the directions are not reciprocal. That is, I go ne to get to a certain room but sw does not return me to the room from which I came. It's se, which doesn't make sense to me.

Keep me updated.


ScaryCat

All the rooms except for one are supposed to be dark when you first enter them, so you'll have to bring the candle with you. Eventually I'll add other working light sources. Just type undo if you get stuck in the kitchen. The upstairs area is not functional yet. When you move from the parlor to the backroom, there's a message that says your candle was blown out. Just relight the candle with the same command as before.
I'm not sure why that's there. It seems to be the remnant of a briefly misplaced picture. I have to find it in the editor to remove it, but so far I haven't been able to.
I was focusing more on function than descriptions, but I'll be sure to add those now.
The chest doesn't have anything in it yet.
I wanted to show that the shelves were in the corners of the room, but I think I'll change it to just "look".
The incorrect prefixes sometimes happen by default, and I don't always take the time to fix them. I'll work on that now.
I think for some reason printing the message "what is this", makes the help menu pop up. I'll have to rephrase the message to avoid that.
For the fireplace, on and off should not be there, but the tilting thing hasn't been implemented yet.
I'm not sure what's going on with the directions. I'll have to look at that.
Thanks for playing and the feedback!


This topic is now closed. Topics are closed after 60 days of inactivity.

Support

Forums