The command: ENTER [SOLVED]

Does the ENTER command actually do anything without adding any scripts?

It doesn't seem to do anything...

What does it do?

Why isn't it just a verb?

Wouldn't it always have to have an object anyway?

(Am I overlooking something?)


And where is it???

I can't find it by any method I can think of (even using grep to search the Quest 5 directory or iterating through AllCommands()).

The message is misleading. The "enter" script is used for a room when the player enters a room, so cannot also be used for a verb. You could add your own command.

Oh, yeah...

The "enter" script!

That is a good script to have!

Much more important than an ENTER verb, I must say.

Thanks, Pix!

This came up about a year ago when someone tried to add an "enter" verb, and it caused havoc, so the warning got added in 5.7.1.

Well, adding that warning just saved the day for me. (Havoc would have been wreaked!)


Adding this to the game allows me to just use an "enter" verb:

  <verb name="enter_verb">
    <pattern>enter #object#</pattern>
    <defaultexpression>"You can't enter " + object.article + "."</defaultexpression>


That's much easier than fooling around with a command, especially if you have more than one scenario when the player could enter something.

Log in to post a reply.