Static Image works...Until, it doesn't

The game I've been working on for about two and a half years has a problem I am unable to figure out. I am hoping someone will be able to help me resolve it, so that I don't have to scrap it.
In the game interface I selected, Picture Frame: A static picture that appears above text.
For the most part it works quite well. When I play through the game it seems to work just fine. Yet, when others test the game...I think they click the directional, move buttons too quickly or something...not sure. But after awhile, the text slips up behind the static picture. Sure you can scroll the text back down. But at that point, unless the player manually scrolls after every move, they are bound to miss something.
I might also mention I have it set the clear previous turns, so that the text doesn't build up.
The static pictures in my game are very important to the game play. So, I can not just do without them.
Any ideas on why it works great for the most part and suddenly starts doing this, would be helpful.
Thanks in advance...


Haven't heard any suggestions on this...I hope you all understand my problem.
The game code is almost 15mb...so there is no way I can upload it here.
If you don't know what I am talking about...please ask. I will try to be more clear.
I really don't want to give up on a game that I have worked so long on just because I can't figure this out.
Please help...


the text slips up behind the static picture

Isn't that what "static" means?
What do you want it to do?


The picture is supposed to stay above the text. I don't use the game map. my pictures are the map as you move. It works for most the time...but once it slips behind the picture, I haven't been able to find a way to make it go back.


Log in to post a reply.

Support

Forums