Memory Error

During the finishing of my game/story, this error popped up onto my screen.
Error: Exception of type 'System.OutOfMemoryException'
Is there a way to solve this, I really need to get this project done.


That is not an error I have ever seen before. Can you give more details? Are you editing/playing on line? Are you finishing editing the game or playing it? What exactly triggers the error message? If playing, then could you post any code that would be running at that time (click code view, and copy and paste the code, even if it means nothing to you).


The last time I saw an "out of memory" error was in the 1980's when a computer MAY have up to 64K of ram!!!


something amusing:

computers' processing power is increasing and so is their memory...

how long would it take for an infinite loop to crash a computer?

processing power (speed) vs memory (size)

it would be a cool experiment to see (have a stop watch with you)!

in the future:

quantum computer vs dna memory (only 4 grams of DNA can hold our/humanity's entire knowledge base: the internet/electronic data and non-electronic knowledge/records/data)


I've had this come up on mine today when trying to load and edit. Online building.

Failed to load game due to the following errors:

  • Error: Exception of type 'System.OutOfMemoryException' was thrown.

Still doesn't load.


Is it more server shenanigans then?


Yep more server problems, it's been a real pain for the last two weeks


and it's down again


Well, I have this king of errors. A lot of them unfortunately. I am using the gamebook mode, by the way.

System.IO.FileLoadException: Could not load file or assembly 'UIAutomationProvider, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. Not enough storage is available to process this command. (Exception from HRESULT: 0x80070008)
File name: 'UIAutomationProvider, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
at System.Windows.Controls.Primitives.Popup.PopupSecurityHelper.ForceMsaaToUiaBridge(PopupRoot

System.Runtime.InteropServices.COMException (0x80004005): Not enough storage is available to process this command. (Exception from HRESULT: 0x80070008) ---> System.Runtime.InteropServices.COMException (0x80070008): Not enough storage is available to process this command. (Exception from HRESULT: 0x80070008)
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr

They pop when I'm using the editor. The size of the project counts, because I have no errors at all until the project grows bigger.
(for instance one of them has 1.87gb of .png images right now)
I tried to work both online and offline with the same results.
Even the issue tracker says that it has no memory!

OS:Win10 Home, 16gb ram, 4gb video card, SSD...

Please help.


So if you move some of the images to another folder, does that stop the error?

It may be you have hit the size limit of Quest. I have not heard of anyone doing that before, but 1.87 Gb of images is a huge amount. If that is the case, you could look at compressing the images.

By the way there is an upload limit of 20 Mb on textadventures.co.uk...


Oh... so my projects will remain just projects.

To answer your question: No. Unfortunately moving images into other folder doesn't solve the problem. Thank you for the fast reply.


So it still happens if there are no images in the folder? How big is your game file? I know someone building a game that is currently 4.7 Mb, and that is okay.


If I don't use images, the editor works fine. The errors are from the images size for sure.
My game file is slightly under 1 Mb. The game works perfectly in play mode. Only the editor gives me errors.
In the task manager when Quest uses about 500Mb more or less, the editor crashes even if I have enough not used RAM.


The editor does seem to open every image; if you try to edit an image in the same folder as an open game, you will be able to as it is already open.

A possible solution would be to have HTML links to the images on another site. That would also mean you can upload the game.


My .aslx file is in the same folder with the .png files (if I understand correctly what you are saying) Probably Quest or my OS limits the usage of memory (RAM, virtual memory...) and I don't know how to fix it. I'm just a guy messing with stuff on a PC, not a pro.

As for your solution to use HTML links, thank you very much. I will consider it.


Quest is 32 bit, so can only use about 3 Gb, which is generally a huge amount. However, as I said, it does seem to open every image in that folder, whether in your game or not, so it is possible that that would get to the limit.


I understand. I'll try to enter a zen state and finish the project as it is, restarting every two minutes.

Your time spent trying to put me out of my misery is very much appreciated.


Log in to post a reply.

Support

Forums