Unable to Launch Gamebook (Desktop Version)

So I just installed this program yesterday, and I've messed around in a Text Adventure. I can launch Text Adventures just fine. I wanted to try out the Gamebook option, so I made one, and launched it to see what it looked like with the pre-built code (I made no changes whatsoever). When I launch it, it gives me this error:

Failed to load game.
The following errors occurred:
Error: Error adding script attribute 'script' to element 'OutputTextRaw': Function not found: 'RequestSpeak'

For the life of me, I can't figure out what the issue is. I've even tried reinstalling Quest, but that did nothing. Can someone help me? This is using Quest 5.

Thanks.


i've been getting this error as well,
but on both the browser version, and the desktop version.
it worked the first couple times for me,
but now it won't load at all.


Browser version also not working for me, desktop version is working. But I didn't update to the newest version of Quest. I believe I'm still using 5.7.2. There's, I believe, early versions of desktop Quest somewhere on GitHub. That might help if you can find it. I couldn't with some quick searching.


I think this is a new problem that just started because I could make a gamebook a few days ago but now I can't.


Yeah, guess this is a problem with the newest version. If you go to the download page of Quest, you can download previous versions. 5.7.2 works just fine.


I just noticed the same problem too. I am using the browser version and not the desktop one. Is there a solution to this problem?


With no answers from the community (who are usually very responsive) either 1) they are working on a solution and don't want to comment yet or, 2) they have decided to abandon gamebook mode support? I've heard rumor from years ago that none of them cared about gamebook mode all that much, although I've gotten great gamebook help over the years... I just hope that's not the case. I'm deep into the middle of a 3000+ page/node open world gamebook (over a number of years) and it would really suck if there's no way to publish it when I finish (again, ashamedly, in a year or two, this project is WAY too huge for little old me, but on I write).


I posted a workaround in another thread. Create a new function:

<function name="RequestSpeak" parameters="s">
  request (Speak, s)
</function>

(This function is required under Quest 5.8, but is only included in text adventure mode; so for gamebooks you'll have to add the function yourself)


I'm seeing lots o' 5.8 problems without very conclusive answers, especially since I'm in gamebook mode (I'm about 900 nodes in with about 3000 planned).

Can I just get a straight answer now, so I don't spend 100s of more hours making my gamebook on a platform that won't support it?

Are you guys done with gamebook mode? I don't mean this aggressively, just wanna know if you guys have abandoned it completely and are now writing code that fucks up the gamebook mode and some random person has to come up with quick fixes for it on the fly?

I'd rather learn a new system now than later.

(and if that's the case, could you politely remove the gamebook mode in future versions?)


No, they are not done with gamebook mode. There are always mistakes in every update. Same with every game or computer program.


Hello all!

I just submitted a pull request to add the RequestSpeak function to the appropriate file to fix this issue with gamebooks.

I also think I found the problem with the Javascript files not loading in DevMode.

What other issues are there? (Sorry. I've been working too much to check in lately.)


PS

The ShowMenu function was added to gamebooks. That was thrown into 580 for the gamebook crowd. (Once the fix I just submitted is merged and the next release is available, you guys and gals will actually be able to use that!)


Until the update comes, we can follow these steps (which were posted by mrangel).

Desktop authors who are fluent in Full Code View can expedite the process like this in full code view.

...and yes: this will need to be done once for each new gamebook story until the next update is available. (Sorry!)


Log in to post a reply.

Support

Forums