Please help - bug - cant add script

Everything was working fine, then all of a sudden I started getting this bug.
I am simply trying to add a verb and script to an object, but it will not accept any script that I enter, after I exit the script editor, the script value is blank.
This happened while I was adding several verbs/scripts to an object, the first few worked fine, then it just stopped working. I have uninstalled and reinstalled Quest to no avail. Is my .aslx file corrupted somehow? Has anyone else experienced this?


Additional info - I tried creating a new project to see if just my project was corrupted, but I am having the same issue. It will not let me add scripts. I tried adding scripts in other places, not just object/verb, and I cannot do that either. It's accepting no scripts. My previously existing scripts are working fine.
The built in script generator is working fine, but I cannot use the script editor to create my own, it just results in a blank script. I am sure the syntax is correct, testing with a simple script.

For now, it looks like I can directly put these scripts in using the Code View. It's just really inconvenient that the script editor is not working.


Does your game play? If it does, trying saving the game during play. For some reason, saving does extra error checking, and the error message might be a clue (though it may not be that helpful!).

Also, try creating a new game, and see if you have the same problem. If not, then there is something off in your game file. Could you post it here so we can see it?


Yes it plays perfectly fine. I tried saving, didn't seem to do anything. I have tried creating a new project, uninstall/reinstall, etc.. nothing! Very odd. It just seems to be a bug with the script editor, it's not writing the contents into the game code. When I use script builder tool it seems to be working, but I prefer to script manually as it's much faster. It's just very strange as it was working fine for the few days I've been using it, and all of sudden stopped working.


Ahhh I have an easy fix! Once I finish editing the code, if I click the 'Code View' button again then the script is properly assigned.
Maybe that's how it was behaving to begin with, but I swear I didn't need to hit that button before?


Log in to post a reply.

Support

Forums