Strange Errors since 5.8

When entering one specific room, I'm getting this.

Error running script: Error evaluating expression 'GetAllChildObjects(room)': Collection was modified; enumeration operation may not execute. 

Error running script: Error evaluating expression 'ListCombine(ScopeReachableNotHeldForRoom(room), ScopeVisibleNotReachableForRoom(room))': Value cannot be null.Parameter name: collection, 

Error running script: Cannot foreach over '' as it is not a list and Error running script: Error evaluating expression 'ListExclude(ScopeVisibleNotHeldNotScenery(), game.pov)': Object reference not set to an instance of an object.

I'm not even sure what "collection" is referring to.

Anyone have any ideas? I think it may be referring to a specific item but I'm not sure.

Anonynn.


I get errors, too - something about dictionary values not found (last post in Quest 5.8 topic). Those errors always pop up while launching a game for editing and then scrolling through the object list. No clue how to fix that, though.


I had this too and couldn't find any clues in the error messages. I decided to uninstall Quest 5.8 and re-install 5.7.2 then ran that to determine that all was well again. Then I clicked on the UPGRADE button and re-downloaded Q5.8 and ran it. Everything seemed to be OK again after this.
Mind you the file sizes were identical - 30,719Kb. Not sure if this will fix yours but uninstalling first then re-installing has done the trick for other programs in the past and worked again this time too. (at least for me)


Actually @R2T1 I had a similar problem as @Blindtextdev , too, and your solution just fixed it. Perhaps it was a problem not with 5.8.0 but with the upgrade feature from the previous version to the new version. I recommend anybody with this problem to try a fresh install of 5.8.0 like R2T1 said. Thanks a bunch!


Good to hear that I could help.


When entering one specific room, I'm getting this.

The library CoreScope.aslx includes all the variable names and lines of code quoted in your error message. But the only way I can see those particular errors coming up in that order is if the player object's parent is unset at the end of the turn.

If there is code that would be run in that room which includes game.pov.parent = SomeFunction() or MoveObject (player, SomeFunction()), check that your SomeFunction doesn't return null when it gets unexpected input.

Setting the player object's parent to null will leave the player without a parent; which gives exactly the set of errors you posted when it tries to update the "Places and Objects" in the sidebar


Log in to post a reply.

Support

Forums