After compiling my quest file to html, unable to click any links

After I compiled my quest file using a quest compiler, the links dont work. Left clicking, right clicking, middle mouse clicking, nothing worked. Not a damn thing. I really need help.


Hello,

Sorry, but that's one of the things that we're currently trying to get to work.

A list of a few things that we know won't work:

http://textadventures.co.uk/forum/quest/topic/ssfixax8wkqppibmxuiifw/a-few-questions-from-a-newbie#39b94039-6e24-41b8-91ba-8b6f594e4fe9

More issues which have been reported:

https://github.com/KVonGit/quest-js/issues


The exit links usually work, but none of the command links or verb links work for me. (Sorry. I did warn about that on your last thread, though. I always do my best to keep from getting people hopes up when I know something might go awry.)

The easiest thing I've come up with until we get the links working is disabling hyperlinks before building the Quest game.

image


NOTE: I've never tried to compile a gamebook...

This isn't a gamebook, is it?


EDIT

Yeah, I suck for not warning everyone in a bigger font. I sincerely apologize.

The links will not work when compiling with Quest JS, and, if your game is a gamebook, NOTHING will work.

Sorry about that. I truly hope it's a text adventure!


Hey!

I fixed it (as far as command links are concerned).

Add this last line at the VERY beginning of your game.js file (whether it's a text adventure or a gamebook):

var canSendCommand = true;

Here's a link to a gamebook compiled with Quest JS:

http://textadventures.co.uk/games/view/egmfigep4ksmgdth8fo2gg/gamebookjs


Here's a link to the newest 'version' of Quest JS (which I just updated):

https://github.com/KVonGit/quest-js/releases/tag/QuestJS_KVmod_20171125


If someone can figure out how to make the verbs list work with a text adventure, I will add that to the file as well. (I'm trying to fix it, but I haven't had any luck yet.)


Have a nice day!


Log in to post a reply.

Support

Forums