Super confused and lost

So I have been messing with Quest for a while and for the life of me have yet to figure out how to move the player to a new "room" with out putting in a exit.
It starts with the intro and I have command:Earth. From there I should just be able to use Exits but for here I need a teleport or something. I have tried making a scripts under the Commands part and from command I have script move object object player to object Earth Deep Ocean.

This whole Quest program is not only going over my head it's doing flips and tricks well doing so.


MoveObject (player, Can 1)


SpawnZombie

Tele 1
MoveObject (player, Can 1)
if (HasInt(game, "crittercount")) {
  game.crittercount = game.crittercount + 1
}
else {
  game.crittercount = 1
}
create ("critter" + game.crittercount)
obj = GetObject("critter" + game.crittercount)
obj.displayverbs = Split("Look at;Attack;Shoot", ";")
obj.parent = player.parent
obj.dead = false
obj.changedhitpoints => {
  if (this.hitpoints < 1) {
    this.dead = true
    msg ("It is dead!")
    player.exp = player.exp + 20
    game.spawn = true
    player.gold = player.gold + 20
    love
    this.displayverbs = Split("Look at;Search", ";")
    Tele 2
    this.parent = player.parent
  }
}
names = Split("Decrepit;Decomposing;Shambling;Disgusting;Filthy;Falling-apart", ";")
obj.alias = StringListItem(names, game.crittercount % ListCount(names)) + " Stallin"
obj.listalias = CapFirst(obj.alias)
obj.hitpoints = 30
obj.damage = 2
obj.attack = 1
obj.defence = 0
obj.armour = 0
obj.selectweapon => {
  if (RandomChance(10)) {
    if (this.weapon = vomitreadying) {
      this.weapon = Spade2
    }
  }
  else {
    this.weapon = GetObject(PickOneString("vomitreadying;talonattack4;Spade2;Spade2"))
  }
}
obj.searchscript => {
  if (RandomChance(4)) {
    player.potion = player.potion + 1
    msg ("You found 1 Potion!")
    RemoveObject (this)
  }
  else if (RandomChance(3)) {
    if (game.hard = true) {
      player.ammo = player.ammo + 7
      msg ("You found ammo! Ammo + 7!")
      RemoveObject (this)
    }
  }
  else if (RandomChance(1)) {
    player.hyper_potion = player.hyper_potion + 1
    msg ("You found 1 Hyper Potion!")
    RemoveObject (this)
  }
  else {
    RemoveObject (this)
  }
}
obj.critdesc = "A well-placed blow by #attacker# sends you reeling (#hits# hits)."
obj.attackdesc = "#Attacker# has hit you (#hits# hits)."
obj.missdesc = "#Attacker# misses you."

Tele 1

player.current_room = player.parent
player.old_room = player.current_room

Tele 2

player.parent = player.old_room

how do you want to do the teleport? how do you want this first part of your game to be designed and functions?

  1. clicking on a hypertext link at the bottom of your intro text
  2. having to type in the room/page/location that you want to teleport to (are you using the 'Text Adventure' or 'Game Book' version?)
  3. selecting a teleport room/page/location via a menu (in-line:in the text area, or as a popup menu?)
  4. after your intro text, you interact with an object or whatever in your intro room, which causes the teleportation stuff to be brought up or occurs

the reason for this question, is by having direct instructions on what you want, we can create a demo game for you, which would allow you to hopefully learn/understand how it works the quickest, as you can study it within the GUI/Editor, and see what we did and how we did it

as it's probably a lot harder for us to try to explain all of it to you and for you to get all of it via our explanations... (at least for me anyways, as I suck at explaining, lol). if you already understand about attributes and data types, then you're a huge step ahead in being able to understand this stuff... if not.... we got to try to explain it all to you from the ground up or from nothing... lots of work

as this topic of "teleporting" (containment) is very broad, there's a ton of really cool stuff you can do... and thus tons of different coding designs/methods of doing those tons of different and cool stuff you can do... lol


here's some general links to learn more about quest, its code structure, and its coding:

http://textadventures.co.uk/forum/general/topic/ljjm32av4e2t9ot49k478g/help#710be61e-eae1-4af1-8363-520cc718ba1c


here's just the concept of how containment actually works in quest:

https://textadventures.co.uk/forum/quest/topic/dkkps3b16uie7i_907876w/random-object-spawn-in-player-specific-rooms#3c0fcc3e-f32b-4f6e-895b-a678e383b0aa

(might not be the best link above... I've written a lot of posts on this stuff... hard to re-find my better posts that explains better this containment stuff... lol... and/or a post that give direct step by step guidance on doing this type of stuff)


if you're able to understand using lists and dictionaries, you can do more fancy containment manipulation (movement) stuff (aka "teleporting"), like randomly selecting a location (npc AI random movement behaviorism), or just having a menu list of choices (adding/removing them as needed) you can goto/warp/teleport to... and lots of etc stuff...

as well as in understanding how containment is really controlled, via the built-in 'parent' Object (reference/pointer) Attribute... allowing you to do some really fancy stuff as well, especially along with lists and dictionaries...

but then you got to know how to apply the scripting into you game code as well


Teleporting AND using the map IS tricky. It only seems possible to teleport to locations that have previously been visited. Is that relevant to your problem?


So I have figured out how to move the player how I wanted to move somehow, but I do have a few questions.

First off is there a way when the game starts to have items already "worn"? I have been looking around and from what I can tell I can't or at least I have yet to find a forum about it I have even looked at the Quest Documentation on the Wearable Items section.

Second how would I go about showing I want to say a list? Like the character steps on something so I have them raise a foot up and see a sharp object and sand. I have both objects parented to the foot and have tried make visible object and other things I have tried just end up as "Error running script: Cannot foreach over 'Object: Sand' as it is not a list.


Use "WearGarment (item)" in the start script for the game. An example is in the Cloak of Darkness:
https://blog.textadventures.co.uk/2018/09/10/the-cloak-of-darkness/


@DavyB Am I just blind? I know I'm stupid but I'm looking at game / scripts tab and start script and I cant find anything like "WearGarment (item)" I have looked at Output / Objects / Scripts etc.

I have looked over the link and its tutorial the example is under the "Wearable cloak" section? I'll keep messing around.

I'm sorry BTW for being a bother.


Sorry! I'd misremembered! The Pixie's version of the game doesn't use the built-in wearable facility. The code I suggested should be fine, however, and is covered in the wearables tutorial:
http://docs.textadventures.co.uk/quest/wearables.html


@DavyB I'll look over the link again.
On another matter I have been trying to add something to a "list" for what feels like a hour and a half.
As I said in a earlier post for example, when my character raises his foot and sees a sharp object and sand none of them show up as options I have tried making a script that makes them visible and nothing shows up I tried show menu and it just tells me it is not a list and I cant just add {object:sand} in the verb. I truly have no clue how to read anything in the Quest Documentation as it seems to tell me what to do with out telling me how to do it.

"To create a list, then, we have three functions:
mystringlist = NewStringList()
myobjectlist = NewObjectList()
mylist = NewList()"

What?!


You don't need all 3 lists. For teleporting, you would use the objectlist.

myobjectlist = NewObjectList()

I actually have my own teleport code.

Game initialization script/game start script

game.rooms = NewObjectList()
list add (game.rooms, The Lab)
game.firstteleport = false

Teleport 1 room, after entering the room script

firsttime {
  list add (game.rooms, Teleport 1)
}
game.firstteleport = true

for lists/dictionaries, see if this helps you:

http://textadventures.co.uk/forum/samples/topic/5137/list-and-dictionary-extensive-guide-by-hk

and try recreating (and adjusting) this for practice with lists:

http://docs.textadventures.co.uk/quest/character_creation.html


ask if you need help with anything or need anything to be explained


@hegemonkhan So I'm looking at the first link and under "Lists (Stringlists and Objectlists) Links:
" section the first link is just 404 file not found.
Besides that I think I need to make a Objectlist key word being I think, since I want a to show a few options. So I would put " mylist type="objectlist">player; object1; thing</mylist " this in somewhere? Like in Code View? To give a example your in a room and interact with a object and that gives a number of other objects to mess around with.
A Objects objects can work right?
Edit: for some odd reason when I add < and > at the start and end the whole thing will not show.


see this post I made in another thread, it might be able to help you (if not, let me know and I'll directly work with helping you until you get it):

http://textadventures.co.uk/forum/quest/topic/1pse3rhtgeegw563gyt5nq/skills-attributes-like-health-magicka-stamina-and-classes#a3b6f48c-0355-40b1-9d19-e586e37720fe (scroll down to the section on lists) (also: scroll down to the dictionary section and at the bottom of it is a code box that gives a pretty good example of a menu selection of choices, and see if you can kinda understand that a bit... or ask and I can try to help you with understanding it, and hopefully you'll then be able to get how to do this type of stuff... fingers crossed... learning to code and do coding concepts, even if using the GUI/Editor, is not easy... took me a long time to learn all of this stuff)

sorry about the links (the site got moved, so that's why my very old post's links don't work as they're the old links to the old site), here are ones that work:

http://docs.textadventures.co.uk/quest/functions/ (categorical order)
http://docs.textadventures.co.uk/quest/functions/index_allfunctions.html (alphabetic order, this is great, as you can find what you're looking for easily, use this page/link of/for finding the functions mentioned in the below links - not going to put/get every list/dictionary function link here, lazy, lol)

http://docs.textadventures.co.uk/quest/using_lists.html
http://docs.textadventures.co.uk/quest/using_dictionaries.html


if you need help doing what you want in/via the GUI/Editor (with all the tabs, buttons, options, controls that you're using in quest), I'll work with you to do what you want... but it takes a lot longer and is harder... as opposed to just posting code and doing it as scripting... though this isn't of much help to new people, who don't know how to code already... let me know if you need to do this using the GUI/Editor (non-code/non-scripting)... and I'll help you through it (I'll need you to tell/explain to me what you want, so I can then walk you through on how to do it with the GUI/Editor)

(best case is that you can understand my code post and match it up with doing it in the GUI/Editor... but this isn't likely... lol)

(it's just a lot more work to walkthrough using the GUI/Editor... as I got to describe/explain everything that you need to click on and etc... its.. a pain... lol)

(though learning to code/script, isn't easy either... but if you can learn it... it's so much faster and easier than using the GUI/Editor, lol)


P.S.

for learning to use lists, this is a really good link/practice (as it helps you with doing it through the GUI/Editor!):

http://docs.textadventures.co.uk/quest/character_creation.html

(also, here was my own attempt at understand its code, back when I first found quest like ~ 7 or so years ago, back when I knew NOTHING/ZERO about coding, lol):

https://textadventures.co.uk/forum/quest/topic/3348/noobie-hks-help-me-thread (main/first page/post)

https://textadventures.co.uk/forum/quest/topic/3348/noobie-hks-help-me-thread#22036 (here's the first post where I'm trying to learn the 'character creation / list' stuff -- keep reading posts after this one too, especially pixie's posts as he does a great job at helping/explaining stuff)

ask if you need any help with it


Well I thank you for all the links and attempted help hegemonkhan but I think I'm throwing in the towel, I fall into the people who don't know how to code. On one hand for me it's just such a overload of things you have to learn and I'm sure I have seen the pieces to do what I want to do I'm just to blind and dumb to see it and put it together.

On the other hand it showed me a new light! Is this what video game creators go through? I can now vaguely understand what video game creators, fan made games and people who post there work on this site go through!

Now I'm not completely giving up I will mess around with Quest here and there to pass some time but as I said I just can't code.

As a side note I had a lot more typed out and closed this window by mistake... I'm sure we have all done it but isn't it just a pain when you spent some time and thought into it.


(filler for getting this edited post, updated/posted)


don't let me scare you with the code... laughs

yes, you're being OVER-WHELMED... like everyone... you're asking about too many different things... which are not easy to understand how to do them, and thus we're (err... I am, lol) OVER-LOADING you with too much junk that you don't understand anything about... lol

let's slow down, and take one thing you want to do at a time! okay?

you can learn this stuff... I'm just sucking at helping you...

we'll get you into a game maker with quest... it is relatively "easy"... I'm just trying to help you quickly... but its too confusing... so we got to take it slower, doing one thing at a time, and by using the GUI/Editor, so no confusing code stuff.


see if this link helps you (it's a lot to read, but i think it can really help, and further down, I do give instructions on how to do it with the GUI/Editor too):

http://textadventures.co.uk/forum/quest/topic/mu7itzjqv0yxrkdwgsbmzg/how-to-make-npc-confront-you-with-chioces#46cdb25b-4767-40a6-8bf4-3cd84e805781


@Lord Krei:

here's also a step by step walkthrough guide with using the GUI/Editor, to understand the basics of Attributes and the Status Attributes displayment:

http://textadventures.co.uk/forum/quest/topic/5387/i-really-need-help#37375

(ask if you need help with it)


let's do this in the GUI/Editor...

what do you want to do first? (I'll walk you through it in the GUI/Editor)

don't give up... I'm just confusing the hell out of you... ignore all my posts.. and we'll take this slow, one thing at a time, and through the GUI/editor, so you can understand, okay?

(or... wait for someone better to help you... as I suck... lol)


Well I do appreciate the help its for starters I miiiiiight have deleted the work I was doing (which wasn't much at last like one or two rooms) for this I will put half the blame on lack of sleep. Second off code is just something I can't do and I will accept that.

Like I said I will still be reading a bunch of these links and seeing if I can find videos on this. Its caught my interest so I will be pecking away at it here and there.


Some tutorial videos by OniMike:

https://www.youtube.com/watch?v=-WNRvCpw3qo&list=PLVDq5KtDCqnZzUqLZ8v-3L7icnvyV6n_d


Log in to post a reply.

Support

Forums