Wearables error

Using the offline Quest, I created a pouch. Under FEATURES tab I selected WEARABLE and now when testing I get this error when taking or trying to wear.
Oh somethings changed. no easy way to show an image.....I'll type it.

Error running script: Error compiling expression 'not garment.worn':
NotElement: Operation not defined for type 'String.
You put it on.

Where do I start looking for this error?


Hello,

Did you create a script to do other things when taking or wearing that item? Or did you just set it up as a default wearable object?

If you created a script, can you copy and paste the script?

Or the code for the entire game, if not too big?


I just made a sample game with one room and one object. I made the object wearable. Then I clicked the Wearable tab and selected CAN BE WORN (it is set on CAN'T be worn by default (for some reason).

My game ran with no errors, but I'm pretty sure there was a release before this build that had some sort of bug... I'm not certain, but I'm fairly certain (and too lazy to look).

This is the build I have:

Quest 5.7
Build 5.7.6404.27031


it may have to do with the fact I'm using pixie's combat.lib. I cannot get armour to work either. I get the same error. If I don't use the wearable feature in quest, it just says I can't wear it.
I'm using 5.7 as well.


welcome back forgewright! Good to see you again!

Pixie's combat 3.0 library has an equipment system already built into it, not sure if you're saying you're also using Chase's Wearables library (which would cause errors - conflicting libraries/codes) or if you're just talking about Pixie's combat 3.0 library.

Someone will help you with it, I'm just not familiar with the libraries, otherwise I'd try to help.


I just updated quest a week ago and hadn't noticed the advance features tab under game features. I may have fixed it. will let you know.


Hey hegemonkhan. yeah ive been here just not posting any issues. My game is getting pretty massive. have to keep curbing it back. just the good stuff, ya know. not using the wearables.lib right now


ah, awesome! You've just been working on a massive game! can't wait for you to finish it!


A new game using offline Quest with no added libraries. Created a leather waist armour. Used wearables feature tab. Have the removable tab checked in feature tab. Works fine to wear or remove.

Then added CombatLib 3. Followed instructions, added attributes to player and CombatInitialise (false) to start script. it will allow you to wear but not remove.
The instructions for Combat.lib 3 says "The attlist" for a heading on instructions to add the Stringlist so I assumed attlist was the key.

I don't know how to add the file anymore or I would.


BTW I know the wear and remove worked with combatlib before the feature tab was added. And I am not using the combat tab on the armour just the wearables feature.

CombatInitialise (true or false) doesn't work. I have removed the lib several times and remove works without it.

I'll try using the combatlib tab instead.


With combat tab I get two wear verbs. One says it is worn but says your not wearing it on remove, the other says it is worn but gives an error on remove.

Also torso is set as slot on wearables and combat tab is set to merchandise with price.

Also when testing with status during play, player defense does not increase


The docs for combatlub say you need clothing lib. This no longer true as it is part of quest so it mat be that removing that library will fix it


Never used clothinglib.


After 8 hours I figured out how to just add a remove verb to the armour. Works great so far. I had the armour script add to agility to get the defense up 1. Now we'll see if I find an error down the road.

But for sure there is a an error on armour using wearables with combat.


I finally figured this out. For some reason when you use the CambatLib with the new wearables feature you cannot remove a merchandise item. such as a pouch you can tie around your neck. I created my own verb for the pouch and found...

RemoveGarment(object)

in core wearables. When I added this to my verb it worked. I will make something up, whether a function or command to fix whatever the bug is with the new wearables feature to run for all my wearable items. Armour still will not work, at least in my program.


I think Pixie's 'merchandise' is for items that belong to a shop/shop_owner, so you can't steal them. But, maybe Pixie over-looked you wanting the merchandise item to be wearable/removable... and there's some conflict or block in Pixie's code from being able to do this for the 'merchandise' items.


This topic is now closed. Topics are closed after 60 days of inactivity.

Support

Forums