Quest problem

Djourner

Let me just start by saying I'm not a dev just a player and my total knowledge in terms of programing amounts to -1/100.
I've been trying to play some games but whenever I start a game, any game, it gest stuck on the first screen.
Everything loads, there is no error message or anything, but when I try to pick any option in any game the program just doesn't process it at all.
I've been trying for quite a while and downloaded a lot of games just for trying and ALLseem to have the same issue, so it wasn't something on the devs end either.
Is this some sort of issue on my pc specifically or am I not doing something crucial?


DarkLizerd

OK, dumb questions first...
Did you download Quest?
Altho, since you said you could see the first screen, I would guess so...
Second... Do you see a directory like tree on the left side of the Quest screen?
If so, you have loaded the game, but not started it... Hit the "> Play" button.
That will start the game.
Second, part 2... do you see the title screen for the game?
This will be different for each game depending on how it starts.
Third... You may have a corrupted copy of Quest.
This would require you deleting, or uninstalling it, and download a new copy and install that.
You will not need to delete the games you downloaded.


Djourner

So in order
1: Yes I did.
2: Yes, I did click play.
3: Yes in most games this is a screen with a few options (usually in text) and basic options right? This is usually the screen I'm stuck at.
4: I actually uninstalled, redownloaded and reinstaled quest multiple times. (I also re downloaded the games multiple times as well, but I do not believe they are the source of the issue)
As a bonus information, I've downloaded and reinstaled versions of quest all the way up to 5.4 at which point some games stopped working... This did not solve the problem.


The Pixie

More basic questions!

What version of Windows are you using?

Does Quest start okay before you load up a game? You should see two tabs, Play and Create.

On the Play tab, can you see a list of games on the left? What happens if you click download for one? What happens if you then click Play?

On the Create tab, what happens if you click Create new game? Do you see a dialogue appear? If you do, type "test" as the name, and click okay. You should now see a list of things on the left, and the setup options in the main screen (sounds like you do). What happens if you do File - Save? What if you click Play at this point?


Djourner

1: windows 7 ultimate, © 2009, service pack 1 (I hope this is what you meant)
2: I see the two tabs, some of the games I downloaded appear on the right, a high rated games list on the left.
3: The game starts, I see what is usually the introduction to world and sometimes options. Some letters appear highlited (they are the choices I can make and stuff I can interact with) I click on them and when there is a menu the menu opens up, but regardless of choices picked the game does not advance beyond the first screen. ( I just downloaded the first game that was on the list 'Victorian detective 2' just to make sure I didn't happen to download 20 bad games on accident last time, but still the same problem I have with every other game, its stuck.)
4: Hadn't tried this one before. The game starts normaly, It says you are in a room and a box prompts me to input commands but since there is no commands programmed nothing happens regardless of what I put in the box. I can see the ui to the right (as in other games) there are arrows, list of items and so on, everything is empty save for the box, the title and the 'you are in a room'. The buttons at the top (file/edit and so forth) all work apparently (in other games they seem to work as well).


The Pixie

Windows version sounds fine; I use Windows 7 too. It does sound like something is broken, rather you you failing to use it properly, which is what we were trying to ascertain without being insulting.

Given you have reinstalled Quest, the next suspect would be .NET. There is a thing to verify .NET on this Microsoft page. I have not tried it, but it might be useful to run it.

https://blogs.msdn.microsoft.com/astebner/2008/10/13/net-framework-setup-verification-tool-users-guide/

After that, you could also try uninstalling Chrome (if you have it) and then (re-)instaling it, as the interface used components of Chrome (but I am clutching at straws at this point).


Djourner
  1. Not sure what I was supposed to with the thing I dowloaded from the link, I just ran the verification and it said it was verified so I tried starting a game again and still nothing... Though I'm not sure if I did it right.
  2. Just did that. Didn't work as well.

Also I don't think anyone has insulted me, but I can be quite dense.
If I sound sarcastic, I'm sorry, I was just trying to be as detailed as possible since I don't know if any of those details are relevant.


DarkLizerd

To me, it sounds like you went through all the steps to verify your problem...
a thought... Win 7 32 or 64 bit?
When I upgraded from win 10 32 bit to win 10 64 bit, I had some problems...
What fixed it for me was installing in the correct programs folder...
Altho, other people running 64 bit did not have the problem.
But I think, in by case, Quest failed to run...
OK, It reported not finding a file, in it's OWN folder, that was my problem...
Yours is different.


The Pixie

Sometimes we get people who have no clue what they are doing, and Quest does not work because they forgot to click Run or something, and we have to try to point out it is trivial without insulting them. Not relevant in this case, as yours is a real problem.

I have not used the verification thing myself, but it sounds like it ran and found no problem, so .NET is okay. And not Chrome. Not sure where to go from here, to be honest.


Djourner

DarkLizerd
I'm running 64bits and I didn't change from one to the other as far as I'm aware.

The Pixie
Yeah, and that is exactly what I needed, I was under the ilusion I was just being dumb and missing out on an obvious step, but it really does look like something is not running like it should.

This is all just mind boggling to me, like, if a message showed up saying what exactly was wrong I wouldn't bat an eye, but nothing seems to be wrong the program is simply not runing... Menus, interface, everything seems to work, just that the games do not move forward... On a blind shot here, but could this be hardware related? Like bad blocks on HDor old RAM? My pc is not all that new.
EDIT: I just tested something, I tried saving and nothing seems to have happened, a file would need to be created on the game folder right? If so then I guess menus aren't working as well.


The Pixie

So is Quest installed here:
C:\Program Files (x86)\Quest 5

And games are stored in a folder:
C:\Users[somename]\Documents\Quest Games

... where [somename] is the user you are logged in as? Are there any folders in that location? Can you edit files there with a text editor? I am just wondering if it is a permissions issue.


Djourner

The Pixie
Quest is instaled in that directory.
And games are stored in that other directory.

It takes a long time to load and I can edit the files with wordpad.
One notice, I actually first tried getting into quest when I downloaded a game from a patreon page, that game was not there with all the other, but I believe quest locates the games in whatever folder you put them into so long as you run that exe first (mostly because that game appeared on the games section every time up until I told quest to remove it from the list).
I think that is just a default folder for games downloaded trough quest directly to go into, I'm not sure if it affects anything.
Another blind shot, has Avast been know to not work with Quest?


The Pixie

If you double click a Quest file, it should open wherever it is, as you say, and it will remember where in the list of recent, I think.

No experience with Avast, so that could be the issue. Worth trying turning it off, but I would be surprised if that was the issue.


Djourner

Indeed, it was not Avast either.
Is there someone I should try to contact for a more in-depth analysis?


hegemonkhan

let's just check if quest itself works or not:

  1. download the 'quest.exe' from this site (have to go to it's main page, not this forum part of the site)
  2. install quest (just double click on the quest.exe)
  3. start/open/use quest
  4. create a new game
  5. let us know if it works or not, as now we got a starting point on at least some direction of where to troubleshoot

R2T1

I can share your frustration as I have had similar problems in the past. This can be a windows permissions problem and I found the best way to prevent it is to not use the default Windows locations for programs.

I'm currently running Quest 5.63 in Win 10 64bit without any problems.

However, when I installed it I changed the directory so that Quest would not be within C:\Program Files (x86)\Quest 5 as I have other programs that can't write files to folders within C:\Program Files (x86)
As you install Quest just change the destination to somewhere else. I use C:\Int_Fiction\Quest 5 (The installer will create the new directory or you could create it before running the installer.) So when the installer gets to the Ready to Install page your information should look something like this...

Destination location:
      C:\Int_Fiction\Quest 5

Start Menu folder:
      Quest

Additional tasks:
      Additional icons:
         Create a desktop icon

Once Quest has been installed, run it and from the menu bar choose Tools / Options then select the Game Browser tab in the Options dialog box. This will allow you to select a path for any games you might download.
When you create your first game you can choose to save it here or somewhere else. I have mine set up similar to The Pixie's.

C:\Users\[somename]\Documents\Quest Games     for games I create
C:\Users\[somename]\Documents\Quest Games\Downloaded Games     for games I download.

I also have C:\Users\[somename]\Documents\Quest Games\Snippits     for small samples and demos

Hope that may go some way to rectifying your frustrations and get you on the path to adventuring.

PS. Can you give us the title of some of the games you have tried unsuccessfully. Perhaps we can try them ourselves and report.
Ideally, if you could also give a transcript as to what you did before it stopped.
eg. opened gamexxx
saw title screen
clicked (something) and got ????
etc


Djourner

hegemonkhan
I believe I already did that earlier, But I did so again just in case.
I see the base title screen for the game i created with menus and UI on the right, but everything is empty as I didn't program anything in. There is a box for comands but no comands I put in it do anything or display any message. Its just the title, 'you are in a room' and the box and nothing else.
I can save the game normaly (from the game creation screen) and create multiple games. Things seem to be working on the game creation front.

R2T1

  1. I tried installing in a diferent folder as well as removing everything quest related from the pc before reinstaling. It is still having the same problem.
  2. The pathing seems to be working okay, Quest does not fail to detect games I have downloaded.
  3. I did a transcript earlier as well (third message I sent)
    As for a game to game basis I can tell I downloaded most of the stuff that appears on the 'get games' menu when I open it. (stuff like victorian detective 2, zombolocaust, the zen garden and so forth). I did so before I sent even the first message to try and determine if it was the games I got where broken, but it seems to happen to every game in quest, so I do not think the games themselves are the cause... Every game opens the first screen, but stops there and none of the options work.

DarkLizerd

Sounds like Quest runs...
It is just not running the games...
Could you start a game, take a picture of what you see, and post that,
I think, if we can see what you are seeing, it may help.
I don't think the side will host you picture, you will need to link to it..
Or, try this,
The game you created, start it, and take a screen shot,
and use that picture for the game's picture,
then publish your game, and upload it as WIP...


Djourner

So I did a screencapture and posted it on youtub, thought it might make things simpler.
You see some games already downloaded, but I only downloaded for the purpose of a previous video (i didn't upload it due to noise), I also downloaded a fresh game to showcase the problem on the video and created a game as well... Hope this helps.
Also the bug with saving is new, it didn't happen when I tried it before, but its probably because I changed the install location due to a tip above.

Sorry about the long silence, I believe no one really wants to hear my voice.
https://www.youtube.com/watch?v=6fDMYIQgv-c


BATMAN007

I cant create a quest game, I'm on phone so maybe that's a problem but I've already created one game on this same phone.
What's happening??!!


The Pixie

Thanks for the youtube. It cuts down a lot of possible issues.

Do you think it crashers as soon as the game starts or when you try to first interact?

Wen you start to play, click the "HTML Tools" button before doing anything else, and click on "Console" along the top. What do you see? Also, what game are you testing with, as some have errors here anyway?

Can you edit a game normally? Tey creating a room, and putting an object in it; create an exit to the start room.

@BATMAN007, I think your problem is entirely different. Could you start a new thread, and give some more details about what you are doing when it goes wrong, and exactly what you see (error messages, etc.)?


Djourner

The Pixie
I started a game as mentioned (Victoria detectiven 2, just to inform) I clicked the html and went to console

At first it was empty, but upon clicking on an option the first time i got:
Uncaught Error: Object reference not set to an instance of an object.
desktopplayer.js:31

Upon clicking again I got:
Uncaught Error: This channel can no longer be used to send messages as the output session was auto-closed due to a server-initiated shutdown. Either disable auto-close by setting the DispatchRuntime.AutomaticInputSessionShutdown to false, or consider modifying the shutdown protocol with the remote server.
desktopplayer.js:31

And then it just repeats. I think this might be the problem, it seems to work up to the moment I click something then stops responding.
Also its the same issue troughout all games (I tried with 'Zen garden' and 'A Story of Salvation'.)

I also tried creating the room as you said, but didn't have any clue what I was doing... I managed to tag everything but had no ideia how to make A go to B or setup interactions.


The Pixie

desktopplayer.js is a file in the Quest program folder, and the bit that is causing a problem looks like this:

function UIEvent(cmd, parameter) {
    questCefInterop.uiEvent(cmd, parameter);
}

Could you open the file up in a text editor (eg with Notepad), and add a new line so it looks like this:

function UIEvent(cmd, parameter) {
    alert("Found: " + Object.getOwnPropertyNames(questCefInterop));
    alert("cmd: " + cmd);
    alert("parameter: " + parameter);
    questCefInterop.uiEvent(cmd, parameter);
}

Open Quest (close it if it was already open, and then re-open it). Create a new text adventure, in English. Click the "Play" button. Open up the console in HTML Tools again, and watch for any error. In the command bar, type "l" (for LOOK), and press return.

A series of boxes should pop-up with some text, that should say this:

Found: uiEvent,toString,equals,getHashCode

cmd: RunCommand

parameter: {"command": "l"}

Tell me what you see and when and if errors appear in the console.

The good news is that we are isolating the error, the bad news is we are heading into areas where I do not know what is going on!


Djourner

The Pixie
I couldn't really put into words so here is another screen cap. First few seconds is just to show the edited 'desktopplayer.js' file so feel free to skip to 0:55

https://www.youtube.com/watch?v=hp7InfmXj6I


Djourner

So... Any tips on how to proceed?


hegemonkhan

so... creating a new game worked fine, it sounds and looks like (but you just don't know how to do anything yet / don't know how to use the GUI/Editor to make your game yet), correct?

to learn how to use quest (its engine: GUI/Editor) to make a game, start here:

http://docs.textadventures.co.uk/quest/#Tutorial

and then, since there's still a huge gap between the tutorial and making your own game (doing stuff on your own), XanMag created a 'tutorial 2', his 'tutorial and templates' guide game: http://textadventures.co.uk/forum/games/topic/5940/quest-tutorials-and-templates-published , as you're having problems still with online play, download XanMag's game file, and play it offline/desktop, hopefully you won't have any issues. There's also Onimike's youtube with guides on doing game making stuff too, but I don't know the link for it, sorry.

ask as you need help, and try to go through the entire tutorial if you can, as it'll help you.


Are you using quest in another language, as that might be a source of problems: non-english quest.exe vs english games


also, Pixie or whoever can help more with the online issue, but maybe it looks like the hyperlinks are causing the problems... does your browser have JS enabled, is there any firewall blocking it, etc etc etc, maybe these are some things Pixie and/or whoever can look into, just throwing out possible clueless ideas, lol. Otherwise, maybe you need some '.net/Cef' file updates...


Djourner

hegemonkhan

  1. I'm not trying to make a game, I only did it in the video because I was instructed to do it to check for issues... But yes, I have no idea how to program anything.
  2. Quest is in english as far as I can tell, all the menus and what not are in english... I believe games are in english as well.
  3. I don't know what JS is, I know its in the error log, but no idea what it is... Also would my browser still be a problem even though I'm actually running the files entirely offline on the program?
  4. I deactivated my firewall and antivirus in most of my testing, aside from those I don't think anything would block quest.
  5. How do I update those?

hegemonkhan

JS (JavaScript, NOT to be confused with the Java programming language. JS and Java are not the same!) web/online/browser programming language:

https://en.wikipedia.org/wiki/JavaScript
https://www.w3schools.com/js/


the 'big 3' main-general programming languages:

C++ (C Plus Plus)
Java
Python


Djourner

So I searched for a .net update and it worked just fine now... I'll leave a link in case anyone encounters a similar problem in the future and if I run into any bugs I'll be sure to come back.
Thank you all for helping.
https://www.microsoft.com/en-us/download/details.aspx?id=48130


hegemonkhan

wow, seriously, it works now? So, it was just a '.net' update that was needed, wow... laughs.


DarkLizerd

WOW!!!
Glad you finally got this fixed!!!


The Pixie

Good to hear it was fixed.


hegemonkhan

@ Pixie:

might want to make a note to yourself: if there's anything related to net issues for people, have them try downloaded/upgrading their '.net' files, lol.


Log in to post a reply.

Support

Forums