Sound workaround issue.

Gamebook. Web version. Long story short, have an area the player will be able to revisit (so first won't work)

I make a script page. I tell it to play sound then go to the next page. The sound won't play.

Why isn't there some kind of wait command? I tried doing it with a while statement, counters and an if statement but this also doesn't work.

It seems to me that it's moving so fast that maybe it skips over the sound. Not sure how to tackle that problem yet, but I've broken my story a few times trying :)

My workaround for this is unfortunately to break up my story further. I wanted to avoid this because I feel like it breaks immersion, but I have no choice.

To clarify, the player routes to let's just call it the NPC page. The page should begin the backround music for the convo and display his picture. Then you choose one of the dialogue options, I set flags based on what is chosen and it gets routed back to the original NPC dialogue.

However when you use the "Action" Music input(the one that has the flag to set for continuous play on subsequent pages...why isn't this an option in the script play sound???) and the picture+text picture, every time you route back to the original npc page the audio starts over, and the picture displays again. I have many dialogue options, so setting a flag doesn't sound too fun to me, I want to set this up and then the next sound played will cut that other sound off.

My problem was that when I tried to do this through script on a blank page, which was show picture, play sound, then change page, it would not work in the actual game itself. I would here a pop kind of sound like something starting picture. no sound. So I thought maybe it just needs some time spent in this page(state) to process my request. I can't seem to add a timer, and I tried this

While expression =false
increase counter +1
set variable = true
go to next page

guess what, that does work logically, but the sound and picture still don't display.

This topic is now closed. Topics are closed after 60 days of inactivity.