"Take" function inconsistent

I've given a sabre, broadsword, flail and dagger "type" attributes in the game object's Scripts tab, each with a value according to their name. For example, the sabre's code goes as follows: set (sabre1, "type", "sabre")) With these applied, if the player tries picking up something too quickly after entering a room (it doesn't have to be one of those items,) instead of the output printing "You pick it up.", a blank new line is added and the item doesn't go anywhere. The object then remains this way until the player restarts the game.
I've tested it with these attributes removed, and the problem goes away. Is there a more efficient way of handling custom variables like this that I'm unaware of? Any help would be much appreciated. Ah, also, I'm using the web version of Quest, if that helps with solving this problem.


I've never seen that behaviour, and can't replicate it. Could you link to a test game which demonstrates the problem?

You found one common way of handling custom attributes on the web editor. Depending on your game structure, it might be easier to put them in each object's initialisation script, so you can easily find everything related to a specific object, but that's more a matter of personal preference.


https://textadventures.co.uk/games/view/phtzfnuo2ekqahno7w6qua/subzero
Apologies for the delay. Upon testing it just a moment ago, it seems like this problem is still happening with the attributes removed and/or moved over to each weapon's initialization script.


I tried playing the game, and I can't get the behaviour you describe. I have to say I'm stumped here, because I can't see any reason that should happen.

Have you seen this behaviour on the desktop player, the web, or both?
How quickly is "too quickly after entering a room"?
Does it happen for all objects?
Is it failing to pick the item up, or just not showing the message? Does it behave normally if you come back later and try to pick up the same item again?


  1. Only the web player; I'm running on OS X, so I can't try it through the desktop player.
  2. I mentioned this since I thought initially it had to do with time, but upon testing it after publishing after my initial post, time seems to have no impact.
  3. Yes.
  4. Failing to pick the item up; no, it remains that way after leaving and entering a room.

And, upon testing the published game again, I ran into the problem when trying to pick up the RFC Canteen object in the kitchen (east of the room at the beginning of the game) on my second test.


I played the game for a little bit. I used my Kindle. Here's what I got.

Take bear skin
I can't see that.

open basket
I can't see that.

take captain's uniform
blah
You pick up the Captain's Uniform.


Just guessing, but it could be because you have an attribute called "type". With the desktop editor, it leads to the game getting mangled when you save and the load it, because the XML reader gets confused, and thinks you are setting the object's type, not setting an attribute called "type".


Log in to post a reply.

Support

Forums