Get Input command for TA [Solved!]

Argent

First off sorry if this has been asked before.

I'm fairly new to Quest, but not necessarily programming. I've actually made a couple of games with the Gamebook mode (unpublished), which I mostly know how to use now, so I decided to give the TA mode a try. I am planning on making a traditional TA style game where the player has to type in the command, but I also wanted to try making a TA which has a gamebook feel. I've used Pixie's guide on how to do that, but my only problem is getting the "Get Input" script to work.

Since I have to get rid of the command bar to get it to be more like a gamebook, I'm having trouble getting the "Get Input" script to work. I figured since a command bar is not required for gamebook, it shouldn't be a problem for TA. So far if I use it, it'll display the message, but skips right over the "get input" script and move to the next one. Is there something I'm doing wrong, or is there another way to get the command bar to show up temporarily for that question/input? Or do I need to have show command bar enabled for this feature to work in TA mode?

Thanks in advance for any help!


XanMag

Okay. I think this will work.

I have not messed with Pixie's guide for Gamebook to TA conversion, but...

I will assume there is a HideCommandBar (or something similar) function in the functions list. If not, you need to add a function. Name it - HideCommandBar and copy-paste this into the code-view part of the GUI.

request (Hide, "Command")

Add another function and call it ShowCommandBar and copy-paste the following:

request (Show, "Command")

Whenever you want to call or hide the command bar, just add a Call Function Script and type in the proper name of the function you want to call, either ShowCommandBar or HideCommandBar

If there is already a Show and Hide Command bar function that you have, all you need to do is call that function to show or hide it.

Again... I hope that helps. I'm not familiar with what you have already, but I just threw a simple game together and it works. Let me know!


Argent

Thank you so much it did solve my problem! This will definitely make my life a lot easier, plus I learnt how to use the call function which I was wondering how to use for a while. So thank you very much!

I do have another question though: if I try to change the colour of the next line of text that's supposed to appear, it doesn't register the input I place the first time, only after the second time I place it.

For example, the game asks a question and the player is supposed to put something in the command bar, the command bar then is supposed to disappear and the next text output is "please press any key to continue" in a different colour. I'm using the wait function for this which will then run additional scripts. However, it seems because I try to change the colour for this one line and then change it back, it's no longer registering the first input but instead I have to type it again. I'm not sure if that's a bug, if it's an odd delay, or if I'm doing something wrong?

Thank you again very much!

Edit: It seems to be happening on and off. It wasn't working about 20 mins ago, and worked fine the last 10 minutes, and now it's not working again...


Log in to post a reply.

Support

Forums