Missing CefSharp.Core.dll or one of its dependancies

I have v5.7.1 running OK on my desktop PC which is still running Win10 build 1607.
However, when I installed it on my laptop (running the Creator's Update - Win10 build 1703), it reports this error.
Error launching Game. Could not load file or assembly 'CefSharp.Core.dll' or one of its dependancies. The specified module could not be found.
But this file is there in the Quest folder.
This only happens when I try to run any game. (Either downloaded or my own WIP)

Has anyone else found this? I suspect there may have to be an update to the CefSharp libraries??? Not sure about this.

I went back and installed v5.6.3 with the same result, which is why I think it is Win10 1703 related and not Quest. (Although maybe it could be Quest source requiring an updated library before compiling??)
I have also tried installing Quest into the C:\Program Files(x86) directory (the default location) and my preferred location - D:\Int-Fict

Any ideas as how I fix this?

Edit - after a bit of "Googling" I found that it might be caused by the absence of VC++ Redistributable package for Visual Studio.
However, I need to know which version of Visual Studio is used for creating Quest in order to D/L the correct files.
(Assuming this is the right fix to apply.)


When I ran into this error, the fix was to install Quest in a different directory.
Win 10, 64 bit I assume...
There is a Program Files and a Program Files (x86).
Try installing Quest in the other folder, or, install Quest in it's own folder.
One of these should fix the problem.


  1. it's an issue with folder location (the new OS' now do this for security reasons, but as can be seen, its default placement into protected folders causes conflicts as needed files are blocked off from being accessed by the computer and/or software you're using), so just simply install the software to an outside folder location, for example the desktop

  2. you can also install (for PCs anyways) the microsoft '.net framework' files possibly too, as this can (and has) fixed some issues people been having as well with quest not working (usually this is for those with older computers though and/or who've not updated/patched these '.net framework' files, having really old file versions of them):

ht.tps://en.wikipedia.org/wiki/.NET_Framework (basically it enables compatibility between various programming languages/softwares/etc, as best as I understand it, which fixes a lot of issues people have)

ht.tps://www.microsoft.com/net/download/framework (download the '.net framework 4.7' or whatever is the current version, you don't need the visual studio as that is a SDK/IDE for programming with C++)

Thanks, but I had already tried those as I said in my post. In hindsight, I wish I had tried it out after the Win10 update. Unfortunately, as I only use the laptop when travelling, I hadn't had a chance to test all my programs. The few others I did try all worked fine.
My copy of Quest has always been outside of the Windows environment. eg. D:\Int-Fict\Quest 5 (This has worked fine till now.)

HK, I'll check out the .NET_Framework files to see what's what. Probably later to day or tonight.
I'll advise then how it all goes.

OK. Downloaded .NET_Framework 4.7 but when I tried to install it, it wouldn't because it was already installed. (Even though I can see no evidence of this in Control Panel/Programs & Features.
I also downloaded and ran C++ Redistributable 2017. - No joy with this either.

Anyone have any further ideas for me to try?

Ok. Running out of hair here. Starting on beard.
Some further testing and googling...
Removed and reinstalled Quest 571. (Turned off laptop in between) - no joy.
Found reference to CefSharp.Core.dll error after Windows 10 update at http://deepbot.deep.sg/forums/index.php?topic=6891.0
Then followed link to Micro$oft - https://www.microsoft.com/en-sg/download/details.aspx?id=30679

Downloaded and ran Visual C++ Redistributable for Visual Studio 2012 Update 4 (64bit version) - no joy.

Downloaded and ran Visual C++ Redistributable for Visual Studio 2012 Update 4 (32bit version) - This gave option to repair or uninstall. I chose Repair.
(While my laptop is 64bit, I believe Quest is a 32bit app so the 32bit version works)

Hallelujah. Following this, I now have Quest running and playing games again.

Just putting all this here for others who follow.


the 'CefSharp' file issues is that individual files are stored all over the place, and those places are protected, preventing for security reasons from the OS' being able to find and access the files scattered all over the place. Thus, this is why the simplest thing to do is to install the software to the (for example) desktop. As few people know the OS/windows environment well (as we're not IT/OS/computer-OS-system experts and definately not OS software engineers, lol):

windows 7+, I think (and probably windows 10 is even more convoluted in folder/file access and management/location/placement/scattering, on top of all of its other convolutions...):

just for some various gaming file scattering locations:

program folder (64 bit) -> WHATEVER folder
program x86 folder (32 bit) -> WHATEVER folder
programdata folder -> WHATEVER folder
users folder -> USER folder -> AppData -> local -> my games folder
users folder -> USER folder -> AppData -> roaming -> WHATEVER folder
libraries folder -> my games folder -> WHATEVER folder

it's very messy (probably helps with security... but for actually getting software to work, trying to find where are the game's save files are located, etc etc etc ... nightmare

though from your figuring it out... maybe your '32 bit' folder location stuff got messed up, or wasn't patched/updated up to current version of whatever files it needed, or who knows what... lol.

The CefSharp files are located within the Quest folder only. The main problem was that when Win10 did it's last update, It didn't update the CefSharp files. My guess is that it was due to me installing Quest into its own folder somewhere other than where the default installation is. If I had installed into the default suggested folders, C:\Program Files(x86), MAYBE windows MIGHT have update the CefSharp files. (Although I don't think so.)
The reason I needed to use the 32bit version is because Quest is built using a 32bit architecture. This is clued by the fact the default install location is C:\Program Files(x86) and NOT C:\Program Files.

Mainly on a 64bit PC, C:\Program Files is for 64bit programs whereas C:\Program Files(x86) is for 32bit programs. The other folders you mention are used by the programs themselves to store relevant program information be that games or applications.
You don't need to be a software engineer as you say, you just need to think things through with a bit of logic.

Anyway, no need to ruminate on why or what happened. I worked through this logically and found and applied a fix which, for me at least, works. If others have a similar problem in the future, at least there is something here that may help them resolve their setup problems. (I hope)

ah, okay.

so you needed to update the 'cefsharp' files, but you did the default install of them, where you needed to direct their install to where you put the quest files/folder.

you know more about the system than I do and/or think more logically rationally, hehe. I just throw out stuff, hoping something will stick, lol.

This topic is now closed. Topics are closed after 60 days of inactivity.