"jQuery is not defined"

I had been using version 5.0 of Squiffy. I have now downloaded Squiffy 5.1.

I created a sample project. It has no text in it except the word "Hello." I choose "Build" in Squiffy 5.1. Then when I try to open index.html in a browser, the page is blank except for "Restart." When I look at the console, I get this message:

Uncaught ReferenceError: jQuery is not defined
    at story.js:611
    at story.js:622
    at story.js:637
index.html:18 Uncaught ReferenceError: jQuery is not defined
    at index.html:18

If I build in Squiffy version 5.0, it works correctly.


Can you try to uninstall the version and reinstall?

In case it does not work for you, try deleting the Squiffy installation folder after uninstalling it and then reinstalling.

I have run a test with Squiffy 5.1 to create a new project and it works correctly.


Ok, I tried uninstalling Squiffy and deleting the "Squiffy" folder that the executable extracted to. I also tried deleting the Squiffy 5.1 installer executable, and downloading a new executable. I reinstalled Squiffy with the new executable, and now I have a new problem: Squiffy won't open. It tries to launch, and an icon for Squiffy shows up in my task bar, and some "Squiffy" processes show up in my task manager, but the actual Squiffy editor window never appears on my screen. Clicking the task bar icon does not bring it up on the screen either. (I am using Window 7.)


I've been having a similar problem and I noticed that the JQuery file in the Build folder is empty. I solved it by copy&pasting the JQuery content from my previous build versions to that empty file.

It's not a long-term solution though since you have to replace it every single time you click "Build" because Build renews the JQuery file which makes it empty again.


Gel225, thanks for the tip! (I'm assuming this is to solve the original problem, not the Squiffy-won't-open problem.)


Update: I got the Squiffy editor to launch correctly. I had to find the preferences file for the Squiffy editor, and delete it. Then I tried installing Squiffy again, and it worked.

Now, back to the original problem, where after I "build," the web page is blank except for "Restart." Based on what Gel225 said, I chose "build" and then checked my jquery.min.js file. That file was blank.

I went into the Squiffy folder, then resources > app > bower_components > jquery > dist and found a jquery.min.js file. I copied the contents of that file to the empty file, and it worked!

But, similar to what Gel225 experienced, that file gets written over every time I build, and is empty again.

Is there a more permanent way to deal with this?


I reported this on Github: https://github.com/textadventures/squiffy/issues/74


I uploaded a new version (5.1.1) for fixed the jquery copy error.

Can you download this version and try it?

http://textadventures.co.uk/squiffy

Thanks!


I tried 5.1.1! It works! Thank you so much!


Log in to post a reply.

Support

Forums