having problem with documented if statement

I can't get this to work. It returns null 1 1 1 1 when I run it in squiffy. The if statement is straight off the documentation. Thanks.

@set a = 1
@set b = 1
@set c = 1
@set d = 1
{if a=1:{@b+=1,c-=1,d=2,not e}}{else:{@b+=2,c+=2,d=3,e}}
{a}
{b}
{c}
{d}


I copied your code and pasted it in directly, and it seems to work for me:

image


image


I'm running Squiffy build 5 on a mac and it definitely does not work there. I just cut and pasted again from your post and it returns
nul 1 1 1 1

It must be a bug then ?


Huh...

I tested it everywhere but in my desktop version (which is Build 5.0.0 on Windows 10), and...

image


It looks like it's buggy in Windows, too.

What happens if you build the game and play it in Firefox?


Ok, if I run the code on a browser, Chrome, under windows it works for me too. So then it is a software bug in the compiler under Mac on build 5.


In that case then I can say that on mac build 5 the squiffy.game.go ("section") also does not work !


Try squiffy.story.go("section")


Same {if} bug is in the desktop Windows version, build 5.0.0.


Log in to post a reply.

Support

Forums