Problem with @ inc variable

Is there any way of making @inc fightingLvl not appear? I put it in to increase the fightingLvl every time Fight is chosen, but it keeps popping up with the rest of the text when I publish it fightingLvl is greater than 0. This is what I am doing.

[[• Fight]]:
{if fightingLvl>0: @inc fightingLvl}
{if fightingLvl=0: Death 1}

{if fightingLvl=1: Death 2}

{if fightingLvl=3: Survive}


Okay, I see your problem.

Unfortunately, as far as I am concerned, there is no way to get the '>' or '<' symbols to work in squiffy.

Troubleshooting options:
Try quest gamebook or use this code:

[[• Fight]]:
@inc fightingLvl (amount to increase by)
{if fightingLvl=0: Death 1}

{if fightingLvl=1: Death 2}

{if fightingLvl=3: Survive}


Hello.

I just tested this out, and it works for me:

{if fightingLvl>0:{@fightingLvl+=1}}

http://docs.textadventures.co.uk/squiffy/attributes.html


Thank you guys!


Log in to post a reply.

Support

Forums