Windows Version Corrupted - Files lost

I downloaded the Windows Offline version and continued to work in my game there when somehow the program slowed down, froze and then closed itself. (Or maybe I closed it, I can't remember anymore). I have saved some time before and didn't use the program for a couple of minutes. I am not sure why it ended up freezing in the first place.

Now, when I open the program or the .squiffy file of my game, it shows me nothing but dots on a red background.

Is there a way to open that .squiffy file on the online version and see of that works? Can someone else check on my quiffy file and see if that is still ok? If I reinstall the Windows version of Squiffy, will that NOT maybe delete my work and cause me to loose it forever? Are there any progress/temp copies of my file somewhere?

I am not sure what to do, it was a lot of work and it's just gone.

For any tips I'd be very grateful.


Have you tried opening your squiffy file in a text editor?


I'm sorry to hear this. KaiSD has a good idea - if you can get those files open in any other viewer, you could then paste them back into the squiffy editor and see if that works.

Something I always do (and this comes too late, of course). If I'm working on a game called filename, I always save a new version, i.e. filename1, filename2. I do this at the start of every coding session. This way, in case I enter a command that crashes it somewhere and I can fix it, or the editor conks out, I still have various working versions. When I'm ready for release, I rename it back to filename, save off all the other versions, and ship it to my game page.

This was very useful when I discovered that the editor was not listing any new sections I'd added. They would run like normal sessions, and you could see them on the screen, but the pulldown list of sections wouldn't work right. I ended up going back a night or two to a version that worked fine, and then pasting the new sections in (from a txt file, as KaiSD suggests) one at a time until everything was rebuilt.

Hope you can restore.


Thanks for the suggestion, KaiSD.
I tried opening the file in notepad, wordpad and libreoffice. All three show me a LOOONG file to scroll through, however, the first two are blank, the latter shows me nothing but hashtags.

I am not sure what that means but it looks... blank and hopeless. :/

If I get enough motivation to try and retype it all I shall keep in mind to save in separate files.


I strongly recommend using GIT. It can be used locally, and it's a fine tool to keep your version history intact.


Log in to post a reply.

Support

Forums