Climb in and out of a cupboard inside a room

Hi guys,

If anyone can help me with this I'd really appreciate it. I've searched for ages through the documentation and through other forum posts and haven't yet found what I'm after.

Basically, I have a room called hallway. Inside hallway is an "object and/or room" called cupboard.

I want players to be able to look at, open and close the cupboard, put things in and take them out of it etc. All that's fine. But I also want people to be able to climb into the cupboard.

I tried setting an exit from hallway to the cupboard (and vice versa), using the normal directional method. But when I then use the exit, it glitches out the map, puts the cupboard too far outside of the room. I don't want the map to show the cupboard outside of the hallway at all.

So I tried using the "In" exit command. But I can't figure out how to choose that exit when in the hallway.

Can anyone point me in the direction of a tutorial for how to set up a cupboard object that is also a room that you can climb into, while staying inside the parent room that the cupboard is in?


Apologies for being such a noob, I've realised this is best put in the Quest forum, but I can't figure out how to delete this post, so I'm just going to repost over there. If there's a mod who sees this please feel free to delete the post in this forum.


Actually, I keep getting the message "you can't post that here" when I try reposting the above to the Quest forum. So I guess I'll have to just leave it here. If anyone does have an answer I'd be very appreciative. Apologies for posting in the wrong forum and not knowing how to fix it. Would also happily take any advice about how to use the forum better!


You should be able to use in/out exits just like any other exit; they should put the rooms in the same place on the map.

So I tried using the "In" exit command. But I can't figure out how to choose that exit when in the hallway.

What's the problem? Seeing the exit when you play the game? You can use it the same way as any other exit; entering "go in", clicking the 'in' button on the compass, or clicking its link in the "You can go:" description.

If that doesn't work, could you show us the game so we can try to find the problem?


An alternative method would be giving the cupboard a "climb into" verb, which just does something like game.pov.parent = this. That might be more intuitive for the player, but you would need to make an exit as well so that it will set the room's grid coordinates.


Log in to post a reply.

Support

Forums