CombatLib

When I am trying to add CombatLib to my game, I am taking this error:
Invalid XML: For security reasons, DTD is not allowed in this XML document. To enable DTD processing, set the DtdProcessing property to Parse on XmlReaderSettings and pass the setting to the XmlReader.Create method.


As far as I can see, CombatLib doesn't contain a DTD. So my first guess would that the file you have is somehow not the right one.

If you open the library in notepad or similar, what are the first few lines?


I can't open it because it says: archive format unknown or corruptIt can't be unknown because I am using the latest version of winrar but either I don't think it is corrupted because I can't recover it with winrar or any other programs.


How are you adding it to your game if you haven't extracted it?


There is the prblem, I can't extract it because it is giving me the error that I post in my last reply.


Are you downloading the library from the following link?

https://github.com/ThePix/quest/blob/master/CombatLib.zip

You have to click the "download" button to save the .zip file (or you can click that link I just created and click "Save", if you trust me (but I wouldn't trust anyone, including me, if I were you).

From there, you should be able to unzip it using Windows 7's or Windows 10's built-in functionality (just right click and extract), or you can use 7Zip. I've tested file extraction using both of those, but I do not have WinRar to test it with that.

From there, you should be able to follow the instructions to add the library to your game to get it working.


If you have tried all that and still have issues, The Pixie should eventually see this post and help you out.


NOTE

If this is the first time you've tried to add a library to a game, I strongly suggest creating a practice game in which you add a very basic library file to a very basic game, just to get the hang of using libraries.

CombatLib is a complex library, and having a greater understanding of how libraries generally work in Quest will definitely help you out while creating a game using CombatLib.


I extracted the zip file into a folder and then I add Combatlib.aslx into the game. But I take this error:
Cannot find a file called 'templates.xml' in current path or application/resource path


I extracted the zip file into a folder

Did you put them into your game's folder like the instructions say?


I didn't, But now I did it and it finally worked! Thank you for everything.


Log in to post a reply.

Support

Forums