Server error happening for the last 2 or 3 days...can someone fix it?

I've been trying to access games (especially my own) for days (server error). The problem seems to be persisting. The contact page doesn't work either...submission of a message takes you to some weird website. Can someone give us an update as to whether the server will go back up soon? I know this has been a problem before, but in my experience, it's never been this bad. There are other people posting about the same issue.

Yeah same for me

Can they fix this for goodness sakes,it's been an issue for ages but now especially

Yeah, it's making me paranoid about my game's future playability...especially for folks that don't have pc's who have no way to play it otherwide

looks like Quest still down with (Server Error in '/' Application.) :(

yup, it's been like that for almost 2 weeks...I'm becoming skeptical of the website's future, as I was depending on it for non-PC users to play my game once it's finished. So, I ported Quest to Crossover so more people could play it. I hope the website goes back up and is consistently working, but I'm not going to count on it for playing the game. I'm just going to promote it as a download in the future.

I tried to contact them on the 26th with the Contact Us link but I got an error so I have no idea if it went through or not. I haven't heard anything back. I even dug up my old Facebook yesterday and tried messaging them there. I got an automated reply in Spanish for some reason? I will let you know if I hear anything back but I'm starting to worry the site has been abandoned at this point...

service is back up, though running a little slow run now...though that changes rather quickly

subsequently, I just found that my game is malfunctioning. Arrow pushes or commands in the text prompt don't work. Always did before, and the server loading time is extremely long. I waited one minute for it to load, then the tech problems presented themselves

Server was down last night.

Games are functioning fine, except saving is failing again.

Can you share or post your crossover install? I can't get crossover (or wine) to work with .net. Quest doesn't seem to be in the crossover registry. @Vurt834

It's happening again for me unfortunately. I hope this gets fixed.

I'm getting "500 - Internal server error". Is that the same for others? OK!

This topic is now closed. Topics are closed after 60 days of inactivity.