[SOLVED]Download issues

Hello, I hope someone could answer this. For the past few days I've been trying to either download one of my games to save it or to try and create a new game to work on, however every time I try to do so I get a Runtime Error and that I have to find a web.config file to set something to "off". Now I'm not sure where to find the file in question (it tells me to look for some "root" of the application, but I have no clue where it is or how to interact with it) or if this is something I can't manipulate.

I am using the web version of Quest on Chrome. Hopefully this is just a one off issue.

Edit: It also appears that I can't edit any of my games now, now sure if this is related or something.
Edit 2: It also seems that I can't play any games on here, again unsure if related to this issue.


Hello.


ORIGINALLY POSTED BY: mrangel
Apr 24, 2021 12:51 PM

It's nearly a week since this question was asked in this forum.

The address to create a game is: https://textadventures.co.uk/create/new

Note that you need to use https:// instead of http:// or it won't work.


We all need to use https for this site. Period.

Online search links will direct us to "http://textadventures.co.uk/", but we need to use "https://textadventures.co.uk/" for everything.

If you have Firefox, you can go into Settings > Privacy & Security and select "Enable HTTPS-Only Mode in all windows" at the bottom under Use HTTPS-Only mode. This will handle it, but you might have to click to allow a connection to an older website which has no https functionality every once in a while, depending upon if you want to and if you ever visit such websites.


@Site_Admin

I wonder if there's a way to have this site automatically redirect everyone to https?

There are tons of posts concerning this issue recently, and we can't ignore people because there's no easy way to let everyone know about this issue in the forums. There are lots of posts, but none of them are slapping us in the face (which is the only most of us will be able to find something, including me).

Heck, I know there are lots of recent forum threads where either mrangel answers or I copy and paste his answer, and it took me a good three minutes to find one of them to link to here.


That doesn't work, while I can reach the page the issue is when I go to click it to create a game it just tells me that Application is missing "/", while mentioning Server Error. It then tells me its a Runtime Error, however trying to find the web.config file it keeps asking about has only messed up aspects of my browser (only one issue remains, though the issue appearing sort of coincided when I lost access to my projects and the other games, though it is most likely a coincidence).

I keep trying different things, even going to different browsers. The only benefit from doing that is I can create new games on different browsers (still getting the same error), however I still can't access any of them as each game either lists itself as Quest or undefined (exactly as they are portrayed).

Edit: Forgot to mention that I can only delete games on the main browser I use, yet the others are unable to do the same. Figured this out the same time I realized I could create them again by bypassing Chrome.


Well, damn. You are correct.

I tried to create a game, and I got the same error whether I used http or https.

https was working just a few days ago.

So, it looks like maybe the server is down.


Well at least its not just me, though the fact this is perhaps affecting others makes me worried. Hopefully what ever is doing this gets solved, without damaging anything...

I'll keep trying to look for something, but darn it if this isn't frustrating.


Same here. I hope it gets fixed soon.


I just sent an email to someone who can fix it.

This happens occasionally. It should be working again sometime soon.


Try it now.

(The online editor works for me now.)


Everything is working again! The only difference is that now I have to use the https to create a game, but otherwise everything works!

Thank you all for looking into this, for a while I feared I was a river without a paddle.


Whoo-hoo!

The server just needed to be restarted (I think). It happens from time to time.

It's always a good idea to post about it on the forum when there's an issue with it. Otherwise, it might go unnoticed for a while, as most mods and admins are busy categorizing games, deleting SPAM, and upgrading things.


Happy gaming!


Log in to post a reply.

Support

Forums